Mantis Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000767sm-sscBuild/Compilation Issuepublic2012-05-02 14:152013-08-29 15:33
ReporterBlazePh 
Assigned ToAJ 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
Platformx86-64OSLinuxOS Version3.x.x
Product VersionStepMania 5 alpha 1a 
Target VersionFixed in VersionStepMania 5 alpha 2 
Summary0000767: Error in RageSoundReader_ThreadedBuffer.cpp causes build failure
DescriptionGCC quits with the following error:
RageSoundReader_ThreadedBuffer.cpp:238:43: error: 'usleep' was not declared in this scope

I'm not familiar enough with the source to know where usleep is defined, but I presume this can be fixed by including the header that defines it.
Additional InformationI successfully built stepmania a few weeks ago, so this must be due to a fairly recent change.

Currently using GCC 4.7
TagsNo tags attached.
Attached Filespatch file icon fix-usleep.patch [^] (753 bytes) 2012-05-02 23:56 [Show Content]

- Relationships

-  Notes
(0001612)
djpohly (manager)
2012-05-02 23:57

Attached fix-usleep.patch, which fixes the issue on my build.
(0001613)
AJ (administrator)
2012-05-03 13:01

Thank you for the patch, I have committed it as revision 48de03985ddc:
http://code.google.com/p/sm-ssc/source/detail?r=48de03985ddc4c5e5bf40cccecebd9b30ac5e964 [^]

- Issue History
Date Modified Username Field Change
2012-05-02 14:15 BlazePh New Issue
2012-05-02 14:32 BlazePh Additional Information Updated View Revisions
2012-05-02 23:56 djpohly File Added: fix-usleep.patch
2012-05-02 23:57 djpohly Note Added: 0001612
2012-05-03 13:01 AJ Note Added: 0001613
2012-05-03 13:01 AJ Status new => resolved
2012-05-03 13:01 AJ Fixed in Version => StepMania 5 alpha 2
2012-05-03 13:01 AJ Resolution open => fixed
2012-05-03 13:01 AJ Assigned To => AJ
2013-08-29 15:33 djpohly Status resolved => closed


Copyright © 2000 - 2011 MantisBT Group
Powered by Mantis Bugtracker